MP-Pistol Forum banner

61 - 69 of 69 Posts

·
Premium Member
Joined
·
147 Posts
Discussion Starter #62
Ok, thanks ShooterGranny

I thought that it needed to be an empty shell case---
 

·
Premium Member
Joined
·
147 Posts
Discussion Starter #64
Just got back from the Range. Shot 4 mags with the 9EZ. No FTFs or any issues at all.

Hopefully it is "Beaking In"

Will continue to lightly polish feed ramp and keep the top of the Follower and Feed Lips wiped down. Not sure if any of that helps. Or, more rounds are helping. Maybe all of the above. lol
 

·
Registered
Joined
·
109 Posts
If you clean the feed ramp thoroughly each time you clean the gun you won't have to polish it with Flitz again. Flitz does take a bit of the metal off each time you polish, so always only use it when absolutely needed.

Happy shooting!
 

·
Premium Member
Joined
·
147 Posts
Discussion Starter #66
I just lightly, for about 30 seconds, use 600grit sandpaper. After cleaning it off. And probably not every time, since I clean both guns after every trip to the Range.

I think the 9EZ is finally acceptable to me. Fingers Crossed.
 

·
Premium Member
Joined
·
147 Posts
Discussion Starter #67
It does take a shot or two to readjust to the trigger pull between my two guns. The Compact has much more travel to it than the EZ. Not a problem, both triggers are fine. Just after 4 mags of the EZ the first shot on the Compact is like "Where's the Wall?".
 

·
Registered
Joined
·
10 Posts
Well finally got back to the range and whats strange is I have not touched the pistol since I shot and used my friends EZ to switch out rsa and mags and it still had issues. I did take it down and wipe the feed ramp off and lube the rails. I was surprised it ran perfectly. So maybe the more I shoot it the better. Never had a pistol that needed a "break in". I'm not sure if thats true or not just mine now seems to be working the more I shoot it. I am talking about steel case ammo as mine has always run aluminum and brass just fine.
 
61 - 69 of 69 Posts
Top