MP-Pistol Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
HI Everyone,

New member here....can't find any online help with my issue: could some of you please assist?

I've had a 5" M&P CORE for 2 years...VERY happy with it. However, I just got an Octane 9 suppressor and a Storm Lake threaded barrel, and now the CORE seizes up and won't cycle after 1 or 2 shots suppressed. VERY frustrating!!!

I put some lubrication on the suppressor piston and still no luck.

I'm thinking that the length of the 5" barrel might be an issue, since I shot the suppressor on a friend's 4 1/2 in M&P with no issues.

Can anyone offer a solution? What do you think is causing the problem? Thanks in advance to all of you...you guys are the best!
 

·
Registered
Joined
·
3,209 Posts
HI Everyone,

New member here....can't find any online help with my issue: could some of you please assist?

I've had a 5" M&P CORE for 2 years...VERY happy with it. However, I just got an Octane 9 suppressor and a Storm Lake threaded barrel, and now the CORE seizes up and won't cycle after 1 or 2 shots suppressed. VERY frustrating!!!

I put some lubrication on the suppressor piston and still no luck.

I'm thinking that the length of the 5" barrel might be an issue, since I shot the suppressor on a friend's 4 1/2 in M&P with no issues.

Can anyone offer a solution? What do you think is causing the problem? Thanks in advance to all of you...you guys are the best!
Does the slide cycle smoothly manually (???) Not sure i understand what the seizure issue is that your talking about...more details please.
What ammo are you using with this suppressor (???)
 
1 - 3 of 3 Posts
Top