MP-Pistol Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey guys, I'm new to the forum. I just bought my first m&p about 2 weeks ago. Finally got a chance to take it out and run it today and the slide isn't locking back on last round. After 8 to 10 mags it didn't lock back a single time. I even tried tracking the slide with an empty mag to see if thatd do it and it didn't lock back then either. My thumb isn't on the slide stop while shooting so that's not the issue. It's an m&p pro series 2.0, 5in slide. Any help would be greatly appreciated.
 

·
Registered
Joined
·
431 Posts
Mine worked fine with the new magazines.

However, the older magazines (from years ago when I was shooting a 1.0 9MM) with the new +2 bases on them were doing that. Failing to lock back. Pull the mags. apart (new and old) and saw the old magazine had "shrunk". Shouldn't have as they were never used that much. I ordered some new Wolf +10% magazine springs and that fixed up the old ones. No issues since.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Ok so maybe new, stronger springs may work? This is supposed to be a brand new pistol with brand new mags, loading the rounds in the mag the springs feel stiff but I may just try that and see if it helps.
 

·
Registered
Joined
·
16 Posts
since its new I would contact Smith & Wesson , or perhaps take it back to where you purchased it and see if they have a gunsmith that can look and see whats up with it
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
since its new I would contact Smith & Wesson , or perhaps take it back to where you purchased it and see if they have a gunsmith that can look and see whats up with it
I bought it off of gun broker, but I have messaged the seller on there and am waiting on a reply before I contact smith and Wesson.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
I'll have to get some new ones and try them, I need more mags any how. This was supposed to be a new gun I bought online but mags looked as if they had been used. Not heavy wear but looks like they had at least been loaded a few times. The follower had the lines from bullets sliding in and out of the mags
 

·
Registered
Joined
·
51 Posts
I just bought M & P SKU 11828 5" Performance Center CORE Pro M2.0 non-ported barrel, and mounted my optic on it (Holosun HS 507c V2), but haven't fired it yet. Was also bought through gunbroker.com and the company handling it was TheGunDock.
Mine has those marks on the gray piece at the top of the empty mags as well. I would imagine it is from being test fired at the factory prior to shipment. I have an appointment to shoot at my local range this Thursday, so I will let you know if mine cycles OK and locks back. I have 115 grain FMJ practice ammo, and will also be running through some 135 grain Critical Duty JHP since it is not as safe to run as home defense ammo as some others. Didn't realize when I bought it. Hopefully mine doesn't suffer the same fate...we will see.

Oh, and I also have three extra new OEM mags I bought through various sources so I will try to see if there is any difference, but there shouldn't be since they are all original equipment S & W mags, with the appropriate markings to verify.

SB
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Nice purchase. Yea I assume mine is from the test firing as well, but I have confirmed with the seller I used, colts firearms of Greenville N.C, great seller by the way, but since it is a brand new firearm all I have to do is register it with smith and the warranty should cover the issue weather its needing new mags or whatever. Hopefully yours will run flawlessly. I was shooting 115 grain FM as well as some polymer coated 124 grain competition ammo
 

·
Registered
Joined
·
16 Posts
Hey guys, I'm new to the forum. I just bought my first m&p about 2 weeks ago. Finally got a chance to take it out and run it today and the slide isn't locking back on last round. After 8 to 10 mags it didn't lock back a single time. I even tried tracking the slide with an empty mag to see if thatd do it and it didn't lock back then either. My thumb isn't on the slide stop while shooting so that's not the issue. It's an m&p pro series 2.0, 5in slide. Any help would be greatly appreciated.
Had that happen with one magazine in my M1.0 CORE. S&W sent me a new follower and all is good. In older followers the slide stop step is smaller. It would Jann against them magazine release and prevent releasing. Evidently it would not properly engage the slide stop as well?
 

·
Registered
Joined
·
51 Posts
Nice purchase. Yea I assume mine is from the test firing as well, but I have confirmed with the seller I used, colts firearms of Greenville N.C, great seller by the way, but since it is a brand new firearm all I have to do is register it with smith and the warranty should cover the issue weather its needing new mags or whatever. Hopefully yours will run flawlessly. I was shooting 115 grain FM as well as some polymer coated 124 grain competition ammo
So I went today and ran three mags of 115 FMJ and one mag of 135 JHP Crit Duty and no issues. Slide locked back fine and all fed good. Left and low but first time firearm owner so all in all I was happy to keep them all on the 12 x 12 at 12-1/2 yards..... it’s a start! Trigger supposed to be upgraded on 2.0 vs 1.0 but that is the one thing that felt a little gritty or crunchy...smooth shooting gun though with low kick especially on the 115 grain. My only other 9 mm experience has been a Ruger SR9(correct model?) This is def much smoother and am able to keep on target pretty well even with a beginners grip.
 
1 - 11 of 11 Posts
Top