MP-Pistol Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I went to clean it today put 300 rounds through it. I took the take down lever down to feild strip. Cleaned it tried to put a mad in it to reset the lever it didn't move. So i pull it out when to re dissemble and the slide jamed with the barrel in a weird ass way ive never seen on any of my other MP's after beating it open enough to push the take down lever it went back together. Function tested and put 5 through it to see if it cycled correctly took it back apart re- feild stripped it this time pushed the take lever up but it was hard as **** to push in. Put it back together function tested put 5 thru it. Is the rod bent? Is it that hard really to put back or am i tripping
 

·
Registered
Joined
·
32 Posts
Did you lock the slide back before turning the takedown lever? That is an important step. Then push down the sear release, the little yellow lever inside the pistol. Release the slide stop and the slide comes off easily. To reassemble put the slide back on the rails and slide it all the way back and lock it back. Then turn the takedown lever back up. Either reach in with your finger and push the little yellow lever back up or insert a magazine while the slide is locked back to move it back to the operating position. It is important that your recoil spring is centered in its spot on the barrel. If they are slightly off center the slide will not go on correctly. I have put thousands of rounds through two Shields and never had any issue with field strip using this technique. It is also the technique shown in the owners manual.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
I did i own a few as well it was just on the 1st take down only now the lever moves fine idk maybe i was a tad off but I've done it multiple times now work just like my 40 c its was just weird thanks for the advice brother👍
 
1 - 3 of 3 Posts
Top