MP-Pistol Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Last night I was at the range shooting my M&P9c. I have shot more than 300 rounds without a single failure of any type. I recently bought a second pinky extension mag from S&W. Here's my problem and I'm not sure how to describe it to S&W:



When I fired the pistol using that magazine, the round would fire, but the slide would hestiate as it returned to the forward position...almost catching onto to something. The next round would chamber and fire, but the slide did the same thing. When I used my other 2 mags, no problem at all. Is this the same as the mag drop problem that I've read so much about or is it something else?



Any suggestions would be greatly appreciated.
 

·
Registered
Joined
·
231 Posts
The mag drop problem that you have read so much about it, is the magazine actually dropping out of the well slightly after a shot is fired. The magazine will unseat itself not allowing the next round to be chambered.



Im no armorer however because the problem is happening with only the one mag it sounds like its the mag and not the weapon. Call S&W and describe the issue as best you can they will do whatever they can to help you for sure.



Good luck
 

·
Site Founder
Joined
·
2,889 Posts
First, the mag bodies are the same as the other ones, Take a look at them.



Next: your problem probably lies in the spring, or lack of problem.



Thing is, its a brand new mag, the spring is still stiff, Esp on the pinky ext ones for some reason.



Load it and let it sit somewhere then try it.



I suggest this cause you say you have 300 rounds through the other 2 mags, so they are well broken in.



You probably notice its hard to load the mag also.
 

·
Registered
Joined
·
115 Posts
Jester said:
First, the mag bodies are the same as the other ones, Take a look at them.



Next: your problem probably lies in the spring, or lack of problem.



Thing is, its a brand new mag, the spring is still stiff, Esp on the pinky ext ones for some reason.



Load it and let it sit somewhere then try it.



I suggest this cause you say you have 300 rounds through the other 2 mags, so they are well broken in.



You probably notice its hard to load the mag also.




I second this. I had this same problem and did just as Jester said . No more problem
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Jester / Sigman,



Thank you - The mag was more difficult to load than the other 2. I will load it and let it sit for sometime and then try it again. That's why I love this forum....and my M&P.
 
1 - 5 of 5 Posts
Top