MP-Pistol Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Just bought a new MP 9 Shield EZ. Everytime I put the magazine in (loaded or empty) it pushes the slide lock up. Can not disengage unless pulling back on slide. Locks in open position after 1st shot. Any help?
 

·
Registered
Joined
·
70 Posts
Just bought a new MP 9 Shield EZ. Everytime I put the magazine in (loaded or empty) it pushes the slide lock up. Can not disengage unless pulling back on slide. Locks in open position after 1st shot. Any help?
Does it do this with both magazines? The load assist tab is what activates the slide stop so with a loaded mag I do not see how the slide stop would be pushed up. If you remove the slide and insert a mag you can see where it engages the stop and perhaps see why it is malfunctioning. Since it is new I would contact S&W about the issue .
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I worked with it this morning. Was able to fire about 50 rounds through it before it would jam. Im hoping it just needs to be worked in. Got it nice and clean now ready to go again. THANKS
 

·
Registered
Joined
·
127 Posts
What do you mean by "jamming?"

That would seem to be different from the slide locking open with rounds still in the mag.

It sounds to me like my friends EZ 9 that sticks open with a round stuck on the feed ramp.
 

·
Registered
Joined
·
463 Posts
What ammo are you using?

I would try something different, but it needs to be a suitable defense round (HP). Working 100% with FMJs, but not defense ammo, doesn't count.

It needs to function 100%.

If you can't get it to do that - send it in.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top