MP-Pistol Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
When I field stripped the shield after the Range today I was surprised that my captured recoil spring was now non-captured. Oops. Did I miss something? It looks like the cap piece that threads or is fixed to the internal guide rod came loose at some point. The good news is the gun functioned flawlessly again even after the assembly came apart.

I emailed S&W for a replacement and will await there response. The gun had about 400 rounds through it.
 

Attachments

·
Registered
Joined
·
8,319 Posts
Call S&W at 1-800-331-0852 and they'll ship one to you. You might want to let them know that the original came apart, and that this is your everyday carry weapon, they might make replacing it a priority.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Thanks KR
I will be calling them Monday. Do you know if that missing cap piece is a screw in piece or fixed some other way? Anyway hopefully not a reoccurring problem.
 

·
Registered
Joined
·
60 Posts
I had something similar happen to me. With mine it was just the large spring that came loose. I e-mailed S&W. They got back to me a couple days later and shipped out a brand new one. If you e-mail, it may take a couple days for a response. If you call, you will get action right away. They will give you a new spring though.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
I called S&W today and CS said they will mail out a new assembly. No questions.
 

·
Registered
Joined
·
62 Posts
Excellent. Glad to see it worked out well. Gives additional faith in my pair of M&Ps...as if I needed any.

Appreciate you posting your experience.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
Recieved my replacement Recoil Spring Guide Rod Assembly in mail tonight. Thanks CS at S&W!
I did run my Shield on a training course today with the broken UN-captured assembly any way since had no choice. About 250 rounds. It still ran 100% no failures. Good to know.
 
1 - 7 of 7 Posts
Top