MP-Pistol Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Have field stripped a Shield .40. Upon reassembly, slide lock will not engage. Suggestions?
 

·
Registered
Joined
·
2,605 Posts
Are you pushing the slide far enough to the rear? Have you put an empty mag in place to see if it will engage the slide stop?

If you installed the recoil assembly is a little out of line, it can make racking the slide all the way to the rear difficult.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Have field stripped a Shield .40. Upon reassembly, slide lock will not engage. Suggestions?
Tried realigning spring assembly and attempted with empty clip installed. No lock back.
Have attempted lock back many times, unsuccessfully.
Have put sear pin back in down position. Still no lock.
 

·
Registered
Joined
·
264 Posts
Put the muzzle end of the slide on the edge of a table with empty mag and push down. See if it locks then.
 

·
Registered
Joined
·
264 Posts
Really? I do it all the time when I practice using one hand. I use the front sight mostly but I can do it. Maybe my wording was off. I can see now how that might confuse someone not familiar with the method.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Really? I do it all the time when I practice using one hand. I use the front sight mostly but I can do it. Maybe my wording was off. I can see now how that might confuse someone not familiar with the method.
When I found the right "table" edge,with installed empty clip, was able to get lock. Thanks.
 

·
Registered
Joined
·
2,605 Posts
Really? I do it all the time when I practice using one hand. I use the front sight mostly but I can do it. Maybe my wording was off. I can see now how that might confuse someone not familiar with the method.
I’m familiar with the “method;” but there’s a big difference in pushing against the front sight and “muzzle end of the slide.”
 
1 - 8 of 8 Posts
Top