MP-Pistol Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I am new to the forum so have patients with me. i just purchased my shield 9mm plus and it has been working Revolver Air gun Trigger Shotgun Automotive exterior fine until i tried to break it down after shooting yesterday. the metal tab you see in the picture is stopping the slide from moving forward. I took a little screwdriver and pressed it down to get the slide all the way off. I took the lockdown lever off and back on but did not help. Any advice would be helpful
 

·
Registered
Joined
·
15 Posts
There is a lever/bar in the frame that needs to be pushed down. Find a manual on line and you will see. Alternative some say you can push down the slide release lever and pull the trigger to release.
 

·
Registered
Joined
·
16 Posts
I am new to the forum so have patients with me. i just purchased my shield 9mm plus and it has been working View attachment 18353 fine until i tried to break it down after shooting yesterday. the metal tab you see in the picture is stopping the slide from moving forward. I took a little screwdriver and pressed it down to get the slide all the way off. I took the lockdown lever off and back on but did not help. Any advice would be helpful

same thing happened to mine. That is the slide stop spring. Somehow mine popped out too and getting the slide off bent the **** out of it. I bought a new one on eBay and replaced it myself but it was a huge pain in the ass.

If I had to do it over again, I would send it back to s&w so they can fix it. I would recommend you doing the same.
 

·
Registered
Joined
·
27 Posts
Something similar happened to my Shield Plus. I had sent my slide out to have it cut for an optic. The company is very well reviewed and did a great job with mine. I had put about 300 rounds through the Shield Plus since getting the slide back and there were no issues at all.

Then a couple of weeks ago I was at the range. I had put about 20 rounds through it when all of a sudden I heard a click and no bang.

Dropped the mag to see there was a light primer strike. Figured it was just a bad round, so shot the next round which did fire normally. The next round after that had the light primer strike again. Dropped the mag, and the very next round fired. Tried different ammo, grain, etc- same thing over and over. (Each light primer strike round I dropped from the mag easily fired through my 365xl.)

Anyway, I read that the light strike could be due to gunk or buildup around the firing pin, so when I got home I decided to field strip and do a deep cleaning.

Unfortunately l am not able to get the slide off. I’ve taken the slide off quite a few times before without issue, but this time, I cannot get the slide off no matter what I do. The gun dry fires just fine, racking the slide works, the slide locks back fine, etc.

Not sure what happened but if my issue is related to the other posts here, than S&W clearly has a potential quality control issue, because people are going to not be too happy if they are suddenly unable to remove their slides
 

·
Premium Member
Joined
·
12 Posts
Not saying this is your issue but when I had the issue of slide not coming off easily in my case it was because of the position of the slide spring. The flat sides on the rear of the spring must be oriented Vertically and rounded sides on top and bottom or it will not operate properly and will be hard to remove the slide.
 

·
Registered
Joined
·
713 Posts
The Shield Plus RSA has flat sides and rounded sides???
Interesting!
 
  • Like
Reactions: rugmankc
1 - 7 of 7 Posts
Top