MP-Pistol Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So I’m at a loss. I have a brand new 2.0 Compact. Racking the slide is really...well, grainy and gritty. If I lock the slide back, then release the slide stop it won’t even return without nudging it. I’ve taken it apart and lubricated appropriately. Is this because of the RSA? The end of the spring near the plug seems to be sticking a bit (I can’t depress it very easily). Any thoughts would be greatly appreciated. Should I attempt to shoot it this way? Is it a break in thing? I’ve attached some pictures and can take more.
18208
18209
 

·
Registered
Joined
·
58 Posts
if the RSA is not flush with the slide in battery I would field strip and be sure it is seated properly, if it is not correct it can cause issues. Images of my 3.6 compact
18210
18211
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
That’s the weirdest part..it sits flush. However this time when I stripped and put it back together, it was way out in front of the dust cover. I had to snap it back into place. I ensured it was seated correctly prior to reassembly. I noticed the top of the breech also is rubbing the slide pretty hard as well..causing bare metal to show with just manual slide racks. I guess I’m calling Smith tomorrow.
 

·
Registered
Joined
·
58 Posts
That’s the weirdest part..it sits flush. However this time when I stripped and put it back together, it was way out in front of the dust cover. I had to snap it back into place. I ensured it was seated correctly prior to reassembly. I noticed the top of the breech also is rubbing the slide pretty hard as well..causing bare metal to show with just manual slide racks. I guess I’m calling Smith tomorrow.
I do not know where you purchased but you may want to check with them see if they have a gunsmith that could check it for you I am sure that would be quicker than S&W repair . Also I noticed you have a light on yours, have you tried removing it to make sure it is not causing any issues .
 

·
Registered
Joined
·
9 Posts
This may sound foolish but be sure you have a magazine (empty) seated.
Silly question, I thought the mag's lifted the release to engage it? So no mag, no lift?

Though reading through anything at this point is possible.
 

·
Registered
Joined
·
438 Posts
I would disassemble and clean/check it again.

If everything looks good, and the issues persist, I'd send it to S&W.

Once you do anything significant to try to cure the problem your warranty will be voided, and you will have to pay to have it fixed. Right now it is a warranty repair.
 

·
Registered
Joined
·
69 Posts
When you say "brand new," Do you mean as in you got it from 2nd hand barely used? Or from a LGS sold as rand new or ordered online or what? This almost sounds like it has a wrong part in there.

I have a compact 9 3.6 and a FS 45 (both 2.0) which are the same gun only different sizes. I can't think offhand how what you're describing is even possible unless it has the wrong RSA or even barrel caliber or something.
 
1 - 9 of 9 Posts
Top